Results 1 to 14 of 14

Thread: Daihatsu HiJet EML weird fault

  1. #1
    Join Date
    Jan 2017
    Location
    west Cornwall
    Posts
    283
    My Unit
    Romahome pod on Daihatsu Hi-Jet 1300
    Thanks
    226
    Thanked 215 Times in 127 Posts

    Default Daihatsu HiJet EML weird fault

    Maybe someone on here has some ideas.

    My HiJet has what I can only describe as a weird fault. If the tank gets below half full the low fuel light comes on going round corners etc. - Fine it is a flat tank better early than late!

    Now comes the weird part - the low fuel light coming on for some reason causes the eml to light up, engine runs fine no different it does not go into "limp mode" - when I fill-up the EML light continues operating.

    To get rtid of the EML I disconnect the battery earth for 30 minutes and this appear to clear the fault codes or whatever. No I have not connected an OBD reader to find the codes. Anyone got any ideas?

    Jon

  2. #2
    Join Date
    Sep 2010
    Location
    Between Dover & Deal, in Kent
    Posts
    866
    My Unit
    Demountable on 2003 Suzuki Carry
    Thanks
    7
    Thanked 310 Times in 191 Posts

    Default

    I had an EPS (Electronic Power Steering) light come up on the 1.3 Carry and every time i disconnected the battery it went out and stayed out.
    But it would eventually come back on, so i popped into a friends garage and he put it on a test gizmo and was able to clear the fault code and re-set the ECU.

    He said the reason it would go off every time i disconnected the battery was that this re-set the memory on the ECU but it didn't clear the fault. (until he re-set it) and when the fault repeated itself it turned the light back on again.

    probably best to take it in and get it tested

  3. The Following User Says Thank You to Donk's Dad For This Useful Post:


  4. #3
    Join Date
    Jan 2017
    Location
    west Cornwall
    Posts
    283
    My Unit
    Romahome pod on Daihatsu Hi-Jet 1300
    Thanks
    226
    Thanked 215 Times in 127 Posts

    Default

    Thanks Pete
    I'll borrow my mates OBD gizmo then I can cancel the fault. Oh for the days when vehicles were simple: - either working and OK! Or not working and needed fixing.
    Jon

  5. #4
    Join Date
    Sep 2010
    Location
    Between Dover & Deal, in Kent
    Posts
    866
    My Unit
    Demountable on 2003 Suzuki Carry
    Thanks
    7
    Thanked 310 Times in 191 Posts

    Default

    I started driving and always had Ford Escorts (Mk 1 & 11) both with 4 cylinder, with OHV.
    Then a Mk3 but that had OHC ..a bit more tricky-er (for Me) but none had all the fan-dangled Computer or Emission Whot Nots to go wrong.

    A friend an i swapped engines over from a Mk1 into a Mk11 by parking them nose to nose and lifting one engine out and landing on the ground, lifting the 2nd engine out, swinging it over and in, then lifting the first back in to the gap.

    We both had everything disconnected and reconnected and running in an evening!

    Now I dread to look under the bonnet. (under the seats in the case of Donk ! )

  6. #5
    Join Date
    Feb 2014
    Location
    Deal, Kent.
    Posts
    523
    My Unit
    Currently a Conway Excel Folding Camper
    Thanks
    100
    Thanked 485 Times in 232 Posts

    Default

    Just a thought, try the battery earth. Not the earth supply, but where the battery actually earths to the body.

    i had a Fiat Strada many years ago and the body earth got all gummed up with green stuff giving all sorts of bizarre dashboard lights. I unbolted it from the body, cleaned it thoroughly with WD40 , cleaned up the body earthing point with a wire brush, smothered everything in copper grease and bolted it all back together. Job done, no more electrical glitches.

    Probably isn't this, but worth a try.

    Panda
    These broken wings are gonna leave me here to stand my ground........

  7. The Following User Says Thank You to Pandabloke For This Useful Post:


  8. #6
    Join Date
    Jan 2017
    Location
    west Cornwall
    Posts
    283
    My Unit
    Romahome pod on Daihatsu Hi-Jet 1300
    Thanks
    226
    Thanked 215 Times in 127 Posts

    Default

    Quote Originally Posted by Pandabloke View Post
    Just a thought, try the battery earth. Not the earth supply, but where the battery actually earths to the body.

    i had a Fiat Strada many years ago and the body earth got all gummed up with green stuff giving all sorts of bizarre dashboard lights. I unbolted it from the body, cleaned it thoroughly with WD40 , cleaned up the body earthing point with a wire brush, smothered everything in copper grease and bolted it all back together. Job done, no more electrical glitches.

    Probably isn't this, but worth a try.

    Panda
    Very true Panda, Unfortunately I had everything off the battery box the other day, cleaned and copperslipped - the battery box does get crudded up being a box on the o/s of the vehicle.

    However in this case I think it ties up with the signal from the low fuel bit of the fuel guage - the sequence is literally - Low Fuel Light (flash) - almost simultaneously EML lights up - possibly Italian wiring ... (again ) On the up side it is a lovely buzzy engine I am rapidly falling in love with our little mini Motorhome If I'm not careful Sandra will be getting jealous
    Jon

  9. The Following User Says Thank You to kernowjon For This Useful Post:


  10. #7
    Join Date
    Aug 2015
    Location
    Cardiff
    Posts
    274
    Thanks
    94
    Thanked 92 Times in 73 Posts

    Default

    I have a feeling that this is a common issue on the hijet / fuel gauge not working.

    Not sure what the source of this knowledge is but its in the back of my head somewhere, may be wrong.
    I'd say a fault connection somewhere/failing fuel sender

  11. #8
    Join Date
    Sep 2010
    Location
    Between Dover & Deal, in Kent
    Posts
    866
    My Unit
    Demountable on 2003 Suzuki Carry
    Thanks
    7
    Thanked 310 Times in 191 Posts

    Default

    Just realised what you said, when you said "Italian Wiring"

    The Daihats is of course Japanese, its the Piaggio's that are Italian

  12. #9
    Join Date
    Jan 2017
    Location
    west Cornwall
    Posts
    283
    My Unit
    Romahome pod on Daihatsu Hi-Jet 1300
    Thanks
    226
    Thanked 215 Times in 127 Posts

    Default

    Quote Originally Posted by Donk's Dad View Post
    Just realised what you said, when you said "Italian Wiring"

    The Daihats is of course Japanese, its the Piaggio's that are Italian
    Pete I believe in 1992 they had moved production to Italy - then in 2004 they completed the change to Paggio. Between 92 and 2004 it was a badge engineering exercise. Same truck different name for different markets.

    Jon

  13. #10
    Join Date
    Sep 2010
    Location
    Between Dover & Deal, in Kent
    Posts
    866
    My Unit
    Demountable on 2003 Suzuki Carry
    Thanks
    7
    Thanked 310 Times in 191 Posts

    Default

    Suppose its a bit like the Bedford Rascal that had a Suxuki Engine !

    You live & Learn

  14. The Following User Says Thank You to Donk's Dad For This Useful Post:


  15. #11
    Join Date
    Jan 2017
    Location
    west Cornwall
    Posts
    283
    My Unit
    Romahome pod on Daihatsu Hi-Jet 1300
    Thanks
    226
    Thanked 215 Times in 127 Posts

    Default

    Pete the motor industry is a mish mash world wide. My partner's Vauxhall Corsa - built in Spain. Subaru build a fair proportion of their cars in the USA. VWs from Mexico and Brazil etc etc.
    Jon

  16. #12
    Join Date
    Sep 2010
    Location
    Between Dover & Deal, in Kent
    Posts
    866
    My Unit
    Demountable on 2003 Suzuki Carry
    Thanks
    7
    Thanked 310 Times in 191 Posts

    Default

    I know, its a bit like Frankenstein !

    My wife was given a Jaguar as a courtesy car by her insurance company following a car accident and we were told that under the shell it was basically a Ford Mondaeo.

  17. #13
    Join Date
    Jan 2017
    Location
    west Cornwall
    Posts
    283
    My Unit
    Romahome pod on Daihatsu Hi-Jet 1300
    Thanks
    226
    Thanked 215 Times in 127 Posts

    Default

    A X Type Jaguar - you don't have to look far - even the tail light clusters are the same. In fact the whole tail-end is little more than a bit of trim and different badges, at the time it was designed and brought into production Jaguar and LandRover belonged to Fords - Special Vehicle Division then they flogged it off to the Indians. c'est la vie
    Jon

  18. #14
    Join Date
    Sep 2015
    Posts
    749
    My Unit
    Romahome C15 Hy/lo
    Thanks
    872
    Thanked 647 Times in 321 Posts

    Default

    Quote Originally Posted by kernowjon View Post
    Thanks Pete
    I'll borrow my mates OBD gizmo then I can cancel the fault. Oh for the days when vehicles were simple: - either working and OK! Or not working and needed fixing.
    Jon
    Talking to the previous owner of chitty today when I pulled up on the drive and as I open the door on my car the drivers seat electronically moves back and when I open the door to get in it slides forward, he asked what other fancy gizmos it has and I listed, the headlights move when you go around a bend and the main beam dips up and down automatically and the wipers operate automatically as soon as rain hits the screen, the handbrake is electric and releases automatically, the engine stops when I apply the handbrake, he said how cool it all that and I told him straight that I'd sooner drive and work on chitty any day all day, just a plain and simple engine and vehicle to drive and brings back real driving when you are in charge not the modern car. I reminded him of the cost too, a simple bulb for chitty cost a few pence and I had the glove box bulb go in my car and it's not just a simple bulb job the whole unit has to come out and be replaced at a cost of £75 plus labour. Give me an old car any day.
    "Take nothing but pictures. Leave nothing but footprints. Kill nothing but time"

  19. The Following 2 Users Say Thank You to Jeff Brown For This Useful Post:


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


We use cookies to make this site as useful as possible. They are small text files placed in your browser to track usage of our site but they donít tell us who you are.

By continuing to use this site you are consenting to cookies being placed on your computer. Find out more here: Cookies in Use